Module 3.17 Starting EMS on Mac


#1

I edited the Json file per the module and when starting the EMS with the wsems command I get an error:

[root@fdeca5ab17cf etc]# wsems -cfg /opt/thingworx/microserver/etc/config.json
[INFO ] 2018-02-12 23:02:58,266 wsems: Using config file: /opt/thingworx/microserver/etc/config.json
[FORCE] 2018-02-12 23:02:58,266 wsems: Starting up …
[ERROR] 2018-02-12 23:02:58,270 jsonConfigurator::initialize: Error parsing JSON.
[ERROR] 2018-02-12 23:02:58,270 Main: Error initializing configurator with /opt/thingworx/microserver/etc/config.json
[WARN ] 2018-02-12 23:02:58,270 Main: Trying .booted config file
[ERROR] 2018-02-12 23:02:58,270 jsonConfigurator::initialize: Error reading file. Error: No such file or directory [/opt/thingworx/microserver/etc/config.json.booted]
[ERROR] 2018-02-12 23:02:58,270 Main: Error initializing configurator with /opt/thingworx/microserver/etc/config.json.booted
[WARN ] 2018-02-12 23:02:58,270 Main: Failed to load .booted config file. Reverting back to original.
[ERROR] 2018-02-12 23:02:58,270 Main: Failed to load any configuration file. Exiting…

Below is my config.json file

     { 
                 "ws_servers":	[{
		"host":	"academic-thingworxconnectivity.portal.ptc.io",
		"port":	443
	}],
       "appKey":	"2bf120bb-1f8f-45d7-bb41-c3894b4c1049",

        // Certificate settings
            "certificates": {
        "validate": false
            }
          }

Would appreciate your feedback on where the error in the JSON file is.

Thanks


#2

Hello @Alain648,

I think this might be a certificate issue. Have you saved the certificate of the ThingWorx server in the microserver folder? Also, I would remove the comments, just in case.

Let me know if this works,
Oana


#3

Removing the comments made it work.

Thanks
Alain