I don't get any result with QueryPropertyHistory service


#1

I don’t get any result with QueryPropertyHistory service for allmy created properties. What am I doing wrong? I did everything as described. Enabled logging, assigne the value stream on the right level, changed the property value and nothing is returned by the service. No error message, just an empty result.


#2

I am getting the same problem. Were you able to find a solution?


#3

I cannot see any change in value after setting properties and services for QueryPropertyHistory. The result i got was a Blank result nothing else. Can i get some help in rectifying that small error, because it is causing a problem further. Currently iam at Milestone M6:24 ( And Iam getting an error here too ) It is maybe because of that. I’am getting this error at M6:24 ( Error executing service

Wrapped java.lang.Exception: Property : [NoLowPowerStateUntil] not found on Shipyard_Ckamat15 Cause: Property : [NoLowPowerStateUntil] not found on Shipyard_Ckamat15 )

Thank You


#4

Also this is the result that iam getting after creating EnterLowPowerState Service ( Results

result
Cannot enter low power state until undefinedTry again later or reset Shipyard.NoLowPowerStateUntil.) whereas the actual result in the video is something different. Can i get some help to rectify the error ??


#5

Same here, no results. The Project property of my value stream was blank, so I tried setting it but that didn’t work. I’ve tried changing the Persistant and Threshold properties of the PowerStorage thing, changing the Min/Max Values, and a few other things … no dice.


#6

Hey @Scott177. I am also getting empty result sets returned for both PowerConsumed and the other. I am assuming that it must be a permissions issue for our user to view data from the VS. Have you had any luck?


#7

No, and I eventually gave up and moved on. Hopefully, if it comes up when we actually develop our own solution, we can figure it out at that time (I encountered it during the tutorials). I just didn’t have time to keep hen-pecking to find a solution.

Good luck!


#8

Thanks Scott. I had a look at the variables and discovered that I named mine incorrectly as PowerConsumer instead of consumed hence the variable never populated and the error. On another note with some previous experience with TWX, these type of errors can also be found in the logs section when you running your production work.