Can't download the course completion certificate


#1

I enrolled in course Unpacking the Internet of Things and i successfully finished it, but when i tried to download the certificate by clicking on the download certificate button, it just loaded and show nothing to be downloaded

Kindly help


#2

Hello @Mohamed802,

Please make sure your pop-up blocker is disabled and that you have the latest version of a PDF viewer installed. The certificate could have been downloaded automatically on your computer, depending on the settings of your browser. Make sure to check the Downloads folder.

Let us know if this helps.


#3

Hello guys,

I have encountered the same issue as @Mohamed802. However, I made sure the pop-up blocker is disabled, that the latest version of a PDF viewer is installed on my computer and I still don’t achieve the expected result. Is there any other way to obtain the certificates, besides the process you present?

Regards


#4

Hello @a990,

Could you share here a print screen of your Achievements tab? What browser are you using?

Sorry for the inconvenience!


#5

Sure. Not a problem.


I’m using Chrome, but I’ve already tried with Edge, IE and Firefox.

Regards


#6

Thanks, it Works now after choosing always allow pop up option


#7

@Mohamed802, can you please tell me what browser are you using?

Regards


#8

i used Google Chrome


#9

I used it as well, but I am still not able to download it.

Before the proposed solution that IoTU mentioned, what was going wrong? Did you have an infinite loading cycle after clicking “Download Certificate” button?

I’m just trying to figure out if my issue is the same as yours.


#10

Please try the below steps

  1. Click the Chrome menu on the browser toolbar.
  2. Select Settings.
  3. Click Show advanced settings.
  4. in the “Privacy” section, click the Content settings button.
  5. In the “Pop-ups” section, select “Allow all sites to show pop-ups.” Customize permissions for specific websites by clicking Manage exceptions.

#11

Already did it, but it still doesn’t work.
Thank you anywway.


#12

Can you please provide some guidance in order to fix this issue?


#13

Hi! I’m also having the same issue. Already tried the steps mentioned above but with no luck, there was no certificate to be found in my Download folder.
Also tried with Chrome (both PC and Android), Firefox and IE, and all with the same negative result.
Can you (IoTU Support) provide any help? There are also a couple of coleagues of mine with the same problem.
Thanks in advance!